Alguém pode me auxiliar nas respostas dessas questões de algoritmo?


#1
  1. A operação mod pega o resultado do resto da divisão.
    Ex.: 3 mod 2 = 1
    4 mod 2 = 0
    Utilize esta operação para resolver o seguinte exercício:
    Faça um algoritmo que leia 30 números inteiros e escreva na
    tela a média dos números pares e a soma total de números
    ímpares.

  2. Escreva um algoritmo que lê 10 valores inteiros, um de
    cada vez, e conta quantos deles estão no intervalo fechado entre
    10 e 20 e quantos deles estão fora do intervalo, no final escreva
    estes resultados.


#2

Oii, tudo bem?
Qual é a linguagem que você está estudando?


#3

1-
programa
{
funcao inicio()
{
inteiro numeros[30], somaPares=0, somaImpares=0, contaPares=0, contador
real media = 0
para (contador = 0; contador < 30; contador ++)
{
escreva(“Digite o número[”,contador,"]:")
leia(numeros[contador])
se (numeros[contador] % 2 == 0) { // % = operador mod
somaPares = somaPares + numeros[contador]
contaPares = contaPares + 1
} senao {
somaImpares = somaImpares + numeros[contador]
}
}
se (contaPares > 0) {
media = somaPares * 1.0/contaPares
}
escreva("A média dos pares = ", media, " e a soma dos impares = ", somaImpares, “\n”)
}
}